Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
<(?:(?<tag>[^\/<>\s]+)(?:\s+(?<attr>[^=>]*)="(?<value>[^"]*)")*|\/?(?<close>(?&tag))\/?)>
/
gi
Test String
New
<div id="lorem" class="ipsum">Hello World</div><div class="lorem">Ciao mondo<a href="#">clicca qui</a></div><div id="lorem" class="ipsum">Hello World</div><div class="lorem">Ciao mondo<a href="#">clicca qui</a></div>
Substitution
Processing...