$re = '/(,[0-9]{7}[0-9A-F]{8})+/';
$str = 'C7,22801422CFE0F63 ,2280141C5EF0F63a,22801402EFD0F63b,2280138C5ED0F63c,228024329897530 ,228023829877530';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);