# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"\??(\n"
r"((action_)((object)|(type)|(ref))(_map))|\n"
r"(spm)|(scm(\-|_)(.*?))|(aff_)(.*?)|(algo_)(.*?)|(btsid)|(ws_)(.*?)|\n"
r"(pd_rd_)(.*?)|(_encoding)|(psc)|(tag)|(ref_)|(pf)|(pf_rd_)(.*?)|\n"
r"(callback)|\n"
r"(cvid)|(form)|(sk)|(sp)|(qs)|(pq)|\n"
r"(mkt_tok)|\n"
r"(trk(Campaign)?)|\n"
r"(ga_)(.*?)|(gclid)|(gclsrc)|\n"
r"(hmb_)((campaign)|(medium)|(source))|\n"
r"((sp)((Report)|(Job)|(User)|(Mailing))(ID))|\n"
r"(itm_)(.*?)|\n"
r"(s_cid)|\n"
r"(elq((Track)?Id)?)|(elqTrack)|(assetType)|(assetId)|(recipientId)|(ŃampaignId)|(siteId)|\n"
r"(mc_(c|e)id)|\n"
r"(pk_)(.*?)|\n"
r"(sc_)(.*?)|\n"
r"(utm_)(.*?)|(nr_email_referer)|\n"
r"(vero_(.*?))|\n"
r"(nr_)(.*?)|\n"
r"(yclid)|(_openstat)|(lr)|(redircnt)|\n"
r"(mbid)|(cmpid)|(cid)|(c_id)|(campaign_id)|(Campaign)|\n"
r"(fb_)(.*?)|(fbclid)|(f?ref)|(refsrc)|(hrc)|\n"
r"(gw?s_)(.*?)|(ved)|(s?ei)|\n"
r"(_hsenc)|(_hsmi)|(__hssc)|(__hstc)|(hsCtaTracking)|\n"
r"(source)|(position)|\n"
r"(tt_)(.*?)|\n"
r"(wt_)(.*?)|\n"
r"(hc)|(fb)|(yc)|(fan)|(asb)|(asb2)|(mindbox)|(from)|(sh)|(keywords?)|(feature)|(mlid)|(stid)|(topnews_)(.*?)|(persistent_)(.*?)|(msid)|(rubric)|(lang)|(t?t=)(.*?)|(d)|(s)|(psf)|(sourceType)|(short)|(pdp_ext_f)|(utparam)|(pvid))(=(.*?)|(?=(&|$|\r|\n|\")))(?=(&|$|\r|\"|\n))")
test_str = ("https://yandex.ru/news/story/Prezident_Tokaev_prinyal_otstavku_pravitelstva_Kazakhstana--243e04d37f1419500c9ece814c1d9e30?lang=ru&rubric=index&fan=1&stid=byyvfKwXr5iSKBBZZOVN&t=1641352850&tt=true&persistent_id=176465644&\n\n"
"https://www.aliexpress.com/item/4000317035065.html?pdp_ext_f=%7B%22ship_from%22%3A%22CN%22%2C%22sku_id%22%3A%2212000018551624449%22%7D&sourceType=fd&scm_id=1007.28480.226530.0&scm-url=1007.28480.226530.0&pvid=4ae1761c-d2f8-43f3-a91d-68763fb50e0b&utparam=%257B%2522process_id%2522%253A%2522110%2522%252C%2522x_object_type%2522%253A%2522product%2522%252C%2522pvid%2522%253A%25224ae1761c-d2f8-43f3-a91d-68763fb50e0b%2522%252C%2522belongs%2522%253A%255B%257B%2522id%2522%253A%25224001%2522%252C%2522type%2522%253A%2522dataset%2522%257D%255D%252C%2522scm%2522%253A%25221007.28480.226530.0%2522%252C%2522tpp_buckets%2522%253A%252221669%25230%2523186385%25230_21669%25234190%252319163%2523569_15324%25230%2523132599%25230%2522%252C%2522x_object_id%2522%253A%25224000317035065%2522%257D")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.