use strict;
my $str = 'Senku Ishigami is charecter from a manga series98 onging since 2017.';
my $regex = qr/(?<=[a-z])\d+\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";