package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(\?<?[!=](?<r>[^()]|\(\g<r>+\))+\)`)
var str = `A(?<!B(C)D)E(?<=F)G(?!H(I(J))K)L(?=M(O)P)Q(?>R)S(T)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}