use strict;
my $str = ' <meta name="keywords" content="People, Royals" />
<meta name="news_keywords" content="william,george,charlotte,kate middleton,prinz george,prinz,prinzessin charlotte,royal-family,marys hospitals,royal-fans" />
<meta name="author" content="Blick" />
<meta name="date" content="2018-04-23T14:20:42+0200" />
<meta name="robots" content="index,follow,noodp,noarchive" />
<meta name="contentId" content="8171954" />
<meta name="cXenseParse:recs:articleid" content="8171954"/>
<meta name="contentType" content="news" />
<meta name="cXenseParse:rag-pagetype" content="news"/>
<meta name="contentPool" content="web|mobile|app" />
';
my $regex = qr/(?i)name\s*=\s*['"]?date[^>]+content\s*=\s*['"]?([^'"]*)['"]?|content\s*=\s*['"]?([^"']*)['"]?[^>]+name\s*=\s*['"]?date['"]?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}