$re = '/^a((b(?2)?)a)?(?1)*$/m';
$str = '# pass
a
aba
ababba
ababbabbba
ababbabbbabbbba
# fail
aa
abbaa
abba
aabb
abababa
ababbba
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);