#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "B(?<Seconds>[\d\w]{34})\s"
Local $sString = "Start File" & @CRLF & _
"AXCT XCTrack 0.6.0 - translations: 2017-03-14 17:49:58 on HUAWEI GEM-702L 6.0" & @CRLF & _
"HPPLTPILOT:Kay Starkermann" & @CRLF & _
"HOSITSite:Schwängimatt" & @CRLF & _
"HPCCLCOMPETITION CLASS:FAI-3 (PG)" & @CRLF & _
"HPGTYGLIDERTYPE:SKYWALK Spice" & @CRLF & _
"HODTM100GPSDATUM:WGS-84" & @CRLF & _
"HFALG:GEO" & @CRLF & _
"HFDTE060417" & @CRLF & _
"LXCTDEVICE eyJjYXBhYmlsaXRpZXMiOnsibWVtQ2xhc3MiOjI1NiwibWVtTGFyZ2VDbGFzcyI6M" & @CRLF & _
"LXCTDEVICE jU2LCJuYW4iOnRydWV9LCJkZXZpY2UiOnsiYW5kcm9pZElkIjoiMzRhM2Q1MzBhZm" & @CRLF & _
"LXCTDEVICE I4YmViYyIsImJvYXJkIjoiR0VNLTcwMkwiLCJidWlsZElkIjoiSFVBV0VJR0VNLTc" & @CRLF & _
"LXCTDEVICE wMkwiLCJjcHVBQkkiOiJhcm02NC12OGEiLCJjcHVBQkkyIjoiIiwiZGV2aWNlU3Ry" & @CRLF & _
"LXCTDEVICE aW5nIjoiSFVBV0VJIEdFTS03MDJMIDYuMCIsImRpc3BsYXkiOnsiaCI6MTg0OCwib" & @CRLF & _
"LXCTDEVICE W0iOjE1Ljc0ODAzMiwidyI6MTIwMH0sImZpbmdlcnByaW50IjoiSFVBV0VJL0dFTS" & @CRLF & _
"LXCTDEVICE 03MDJML0hXR2VtaW5pOjYuMC9IVUFXRUlHRU0tNzAyTC9DMjA5QjIwMzp1c2VyL3J" & @CRLF & _
"LXCTDEVICE lbGVhc2Uta2V5cyIsImhhcmR3YXJlIjoiaGkzNjM1IiwibWFudWZhY3R1cmVyIjoi" & @CRLF & _
"LXCTDEVICE SFVBV0VJIiwicHJvZHVjdCI6IkdFTS03MDJMIiwic2RrIjoyM30sInhjdHJhY2siO" & @CRLF & _
"LXCTDEVICE nsidmVyc2lvbkNvZGUiOjYzLCJ2ZXJzaW9uTmFtZSI6IjAuNi4wIC0gdHJhbnNsYX" & @CRLF & _
"LXCTDEVICE Rpb25zOiAyMDE3LTAzLTE0IDE3OjQ5OjU4In19" & @CRLF & _
"LXCTSENSOR Sensors: SENSOR_BT, external GPS:true, external baro:true, intern" & @CRLF & _
"LXCTSENSOR al baro:false" & @CRLF & _
"LXCTEARTHMODEL FAI_SPHERE" & @CRLF & _
"B1505404717336N00740471EA0101001091" & @CRLF & _
"B1505414717336N00740472EA0101001091" & @CRLF & _
"B1505424717335N00740472EA0101001091" & @CRLF & _
"B1505434717336N00740472EA0101001090" & @CRLF & _
"B1505444717336N00740472EA0100901090" & @CRLF & _
"B1505454717336N00740471EA0100901091" & @CRLF & _
"B1505464717336N00740471EA0101001091" & @CRLF & _
"B1505474717336N00740471EA0101001091" & @CRLF & _
"B1505484717336N00740471EA0101001091" & @CRLF & _
"B1505494717336N00740471EA0101001091" & @CRLF & _
"B1505504717336N00740471EA0101001091" & @CRLF & _
"B1505514717336N00740471EA0101001091" & @CRLF & _
"End File"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")