import re
regex = re.compile(r"(.)(?![^(]*\))", flags=re.MULTILINE)
test_str = ("010000000\n"
"(10)1140006x\n"
"002200010\n"
"00000(11)01x\n"
"311200")
subst = "\\1 "
result = regex.sub(subst, test_str)
if result:
print(result)