import Foundation
let pattern = #"(?<=(?:\/CN|,OU)=)([^,]*)(?=(?:,[^,]*)*,DC)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"LDAP://abc.123.net/CN=SERVER123ABC,CN=Servers,OU=Test OU,OU=Test OU 2,DC=abc,DC=123,DC=net"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)