// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)work\/^(admin)").unwrap();
let string = "да http://url.ru/work/guest_del
да http://url.ru/work/big/del
нет http://url.ru/work/admin
нет http://url.ru/work/admin/guest_del";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}