#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w!#$%&'*=?^_+-`{|}~]+[@]+[a-zA-Z]+[.]+[a-zA-Z]+[.]?+[a-zA-Z]+$"
Local $sString = "douglas@gmail.com" & @CRLF & _
"contato@estadão.com.br" & @CRLF & _
"admin@site.com" & @CRLF & _
"pedro@coca-cola.com" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")