re = /^[\w!#$%&'*=?^_+-`{|}~]+[@]+[a-zA-Z]+[.]+[a-zA-Z]+[.]?+[a-zA-Z]+$/m
str = 'douglas@gmail.com
contato@estadão.com.br
admin@site.com
pedro@coca-cola.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end