using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\w+))?\s?\b(\d+)\s?x\s?(\d+)\s?(cm)\b";
string input = @"
30 x 30 cm
30x30cm
30x30 cm
Ixxx 30x30cm
xxxx (30x30cm)
xxxx (30 x 30 cm)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}