re = /(?:(\w+))?\s?\b(\d+)\s?x\s?(\d+)\s?(cm)\b/
str = '
30 x 30 cm
30x30cm
30x30 cm
Ixxx 30x30cm
xxxx (30x30cm)
xxxx (30 x 30 cm)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end