package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(http|www|file)\S+`)
var str = `!play https://www.youtube.com/watch?v=tXGobgt-1Jg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}