$re = '/\+?[(]?(?:[0-9\ ][a-z]?[()\-\.]?){3,}/m';
$str = '+1-023-999-982';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);