Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(([^\n:#]*)(?::([^\n#]+))?)(?:#([0-9A-Za-z]+)(?:\((\d+\.?\d*)\))?)?
"
g
Input 1
1
New
Phospho#g1 Glycan:Hex Glycan:Hex#g1(0.10) #AAA #AAA(0.10) Formula:C6H10O5