import re
regex = re.compile(r"(([^\n:#]*)(?::([^\n#]+))?)(?:#([0-9A-Za-z]+)(?:\((\d+\.?\d*)\))?)?")
test_str = ("Phospho#g1\n"
"Glycan:Hex\n"
"Glycan:Hex#g1(0.10)\n"
"#AAA\n"
"#AAA(0.10)\n"
"Formula:C6H10O5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")