re = /(([^\n:#]*)(?::([^\n#]+))?)(?:#([0-9A-Za-z]+)(?:\((\d+\.?\d*)\))?)?/
str = 'Phospho#g1
Glycan:Hex
Glycan:Hex#g1(0.10)
#AAA
#AAA(0.10)
Formula:C6H10O5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end