# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\\/\\/\[JsonProperty\(Required = Required\.Always\)\])
(public string (My)(Property)(Name) { get; set; })/$1\n [JsonPropertyName("\L$3_\L$4_\L$5")]\n $2/gm;t' <<< "//[JsonProperty(Required = Required.Always)]
public string MyPropertyName { get; set; }"