#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\/\/\[JsonProperty\(Required = Required\.Always\)\])" & @CRLF & _
" (public string (My)(Property)(Name) { get; set; })"
Local $sString = "//[JsonProperty(Required = Required.Always)]" & @CRLF & _
" public string MyPropertyName { get; set; }"
Local $sSubst = "$1\n [JsonPropertyName("\L$3_\L$4_\L$5")]\n $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)