package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/\/\[JsonProperty\(Required = Required\.Always\)\])
(public string (My)(Property)(Name) { get; set; })`)
var str = `//[JsonProperty(Required = Required.Always)]
public string MyPropertyName { get; set; }`
var substitution = "$1\n [JsonPropertyName("\L$3_\L$4_\L$5")]\n $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}