$re = '/(\/\/\[JsonProperty\(Required = Required\.Always\)\])
(public string (My)(Property)(Name) { get; set; })/m';
$str = '//[JsonProperty(Required = Required.Always)]
public string MyPropertyName { get; set; }';
$subst = "$1\n [JsonPropertyName(\"\L$3_\L$4_\L$5\")]\n $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;