# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(\/\/\[JsonProperty\(Required = Required\.Always\)\])\n"
r" (public string (My)(Property)(Name) { get; set; })")
test_str = ("//[JsonProperty(Required = Required.Always)]\n"
" public string MyPropertyName { get; set; }")
subst = "$1\\n [JsonPropertyName(\"\\L$3_\\L$4_\\L$5\")]\\n $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.