#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)<sup>†<\/sup>(.*)|(.*)"
Local $sString = "$128.48 One Month TV Internet and Voice, 100GB of Fiber<sup>†</sup> Internet." & @CRLF & _
"" & @CRLF & _
"$148.48 One Month TV Internet and Voice, 200GB of Fiber<sup>†</sup> Internet and a free movie rental from MoviePlex." & @CRLF & _
"" & @CRLF & _
"$128.48 One Month TV Internet and Voice, 100GB of Fiber Internet. <- without superscript"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)