$re = '/{{\s*lang\(\"(.*?)\"(.*?)}}/m';
$str = '<div class="col-12 col-md-8 offset-md-2 mb-2">
<h5 class="text-danger">
{{lang("SiteCadastro.alterarsenha.erromsg1")|raw}}
<br><br>
{{lang("SiteCadastro.alterarsenha.erromsg2")|raw}}
</h5>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);