const regex = /\{(?:[^{}]|(?R))*\}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{(?:[^{}]|(?R))*\\}', '')
const str = `{"id":0,"name":"Ninja Assassin (2009) [720p] Bluray [filmxy.vip].mp4","size":"682305443"}
{"id":0,"progress":242603704}
{"id":0,"progress":437319904}
{"id":0,"progress":560004744}
{"id":0,"size":682305443,"url":"https://uptobox.com/krafbomfc1qm","deleteUrl":"https://uptobox.com/krafbomfc1qm?killcode=7jgnrwn5fu"}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}