$re = '/http:\/\/[a-zA-Z0-9-:\/.=?_]+/m';
$str = 'http://abc.com/main_img_a, http://abc.com/altimg_a_1, http://abc.com/altimg_a_2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);