re = /http:\/\/[a-zA-Z0-9-:\/.=?_]+/m
str = 'http://abc.com/main_img_a, http://abc.com/altimg_a_1, http://abc.com/altimg_a_2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end