$re = '/^[^ab]*+(?=(?:[^b]*b){2})(?:[^a]*a){2}[^a]*$/m';
$str = '---aabb+++
---bbaa+++
---abab+++
---baba+++
---babba++
---bbbbbaa
ababbb++++
ccabcab+++
----bcdbaa
-ababd++++
bbbaabbbbb
bbbabbbbbb
bbbaaabbbb
baaaaaaaaa
abbbbbbbbb
ccacbcacbc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);