import Foundation
let pattern = #"^(?:\[[^\]\[\n]*\]\s+)?(?<name>[^)(\n]*)\s*(\((?!not|unus)[^)(\n]*\))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[Example] öäüß asdf 1234 (1aö)
[Red] Panda (It's so cute)
[Red] The Panda (It's so cute),
[Red] what Panda (It's so cute) (not necessary),
[Red] it's a Panda (It's so cute) (unusual),
[Yellow] Leopard (the big one)
[Yellow] The Leopard (the big one),
[Yellow] what Leopard (the big one) (not needed),
[Yellow] it's a Leopard (the big one) (unusual),
[Green] Dragon (Fire? It's hot!)
[Green] The Dragon (Fire? It's hot!),
[Green] what Dragon (Fire? It's hot!) (not usual),
[Green] it's a Dragon (Fire? It's hot!) (unusual),
[Blue] Snake (zzzZZZzzzZZZ)
[Blue] The Snake (zzzZZZzzzZZZ),
[Blue] what Snake (zzzZZZzzzZZZ) (not beautiful),
[Blue] it's a Snake (zzzZZZzzzZZZ) (unusual),
Panda (It's so cute)
The Panda (It's so cute),
what Panda (It's so cute) (not necessary),
it's a Panda (It's so cute) (unusual),
Leopard (the big one)
The Leopard (the big one),
what Leopard (the big one) (not usual),
it's a Leopard (the big one) (unusual),
Dragon (Fire? It's hot!)
The Dragon (Fire? It's hot!),
what Dragon (Fire? It's hot!) (not necessary),
it's a Dragon (Fire? It's hot!) (unusual),
Snake (zzzZZZzzzZZZ)
The Snake (zzzZZZzzzZZZ),
what Snake (zzzZZZzzzZZZ) (not beautiful),
it's a Snake (zzzZZZzzzZZZ) (unusual),
Panda
The Panda,
what Panda (not necessary),
it's a Panda (unusual),
Leopard
The Leopard,
what Leopard (not needed),
it's a Leopard (unusual),
Dragon
The Dragon,
what Dragon (not usual),
it's a Dragon (unusual),
Snake
The Snake ,
what Snake (not beautiful),
it's a Snake (unusual),
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)