const regex = /.*\[ERR]\h*(?:\R.*){2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\[ERR]\\h*(?:\\R.*){2}', 'gm')
const str = `2023-03-15 18:14:31.149 -04:00 [ERR]
Exception Time: 3/15/2023 6:14:31 PM
Exception Message: Could not find file '\\\\XXXXX01\\Files\\51372\\Working\\.xml'.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}