#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<num1>\d*)?a?(?<num2>\d*)?b?(?<num3>\d*)"
Local $sString = "111a222b333" & @CRLF & _
"111" & @CRLF & _
"111b333"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)