using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(?:\(\d{3}\)\s*|\d{3})-?\d{3}-?\d{4}\s*$";
string input = @"(404) 666-1111
(404) 6661111
404-666-1111
404-6661111
404666-1111
4046661111
(404) 666-1111
(404)666-1111
404-666-1111
404-6661111
4046661111
+1 (404) 666-1111
( 404)666-1111
404.666.1111
404 666-1111
404 666 1111
(404-666-1111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}