use strict;
my $str = '(404) 666-1111
(404) 6661111
404-666-1111
404-6661111
404666-1111
4046661111
(404) 666-1111
(404)666-1111
404-666-1111
404-6661111
4046661111
+1 (404) 666-1111
( 404)666-1111
404.666.1111
404 666-1111
404 666 1111
(404-666-1111';
my $regex = qr/^\s*(?:\(\d{3}\)\s*|\d{3})-?\d{3}-?\d{4}\s*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}