import Foundation
let pattern = #"^\s*(?:\(\d{3}\)\s*|\d{3})-?\d{3}-?\d{4}\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(404) 666-1111
(404) 6661111
404-666-1111
404-6661111
404666-1111
4046661111
(404) 666-1111
(404)666-1111
404-666-1111
404-6661111
4046661111
+1 (404) 666-1111
( 404)666-1111
404.666.1111
404 666-1111
404 666 1111
(404-666-1111
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)