// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"img.*?title="([^"]+)"\s*src="([^"]+)""#).unwrap();
let string = "<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}