re = /^(?:( *)|([1-9][0-9]*\.?([,-] *[1-9][0-9]*\.?)*))$/m
str = '1, 2, 3
1., 2.
1, 3-5
0, 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end