$re = '/^[^<]*<(?\'Element\'[^>\s]*)[^>]*>(?\'Text\'[^<]*)<\/\1>\s*$/m';
$str = ' ELEMENT ATTRIB="foo"> inner text </ELEMENT>
< ELEMENT ATTRIB="foo"> inner text </ELEMENT>
< ELEMENT ATTRIB="foo"> inner text </ELEMENT>
<ELEMENT>inner text</FOO>
ELEMENT ATTRIB="foo"> inner text </ELEMENT>
<ELEMENT>inner text</ELEMENT>
<ELEMENT>inner text</ELEMENT>
<ELEMENT>inner text</ELEMENT>
<ELEMENT > inner text </ELEMENT>
<ELEMENT > inner text </ELEMENT>
<ELEMENT > inner text </ELEMENT>
<ELEMENT ATTRIB="foo"> inner text </ELEMENT>
<ELEMENT ATTRIB="foo"> inner text </ELEMENT>';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;