#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[12]?\d{1,2}\.){3}[12]?\d{1,2}"
Local $sString = "127.0.0.1" & @CRLF & _
"192.168.101.100" & @CRLF & _
"255.255.0.0" & @CRLF & _
"" & @CRLF & _
"...." & @CRLF & _
"1..0.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")