$re = '/(?:[12]?\d{1,2}\.){3}[12]?\d{1,2}/m';
$str = '127.0.0.1
192.168.101.100
255.255.0.0
....
1..0.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);