re = /(?:[12]?\d{1,2}\.){3}[12]?\d{1,2}/m
str = '127.0.0.1
192.168.101.100
255.255.0.0
....
1..0.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end