// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[12]?\d{1,2}\.){3}[12]?\d{1,2}").unwrap();
let string = "127.0.0.1
192.168.101.100
255.255.0.0
....
1..0.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}