import Foundation
let pattern = #"""
^(?P<mounting_type>Z)(?P<number_of_positions>4)(?P<unit_type>W)(?P<actuation_type>EH|H)(?P<unit_size>22)(?P<spool_symbol>E62|E63)(?P<sep_1>-)(?P<unit_series>5X)(?P<sep_2>/)(?P<pilot_valve>6|)(?P<type_of_solenoid>E|)(?P<solenoid_in_ac_or_dc_version>G|W|)(?P<voltage_of_solenoid>230|220|205|200|180|125|120|110|100|96|48|26|24|12|)(?P<manual_override_unit>N9|N|)(?P<control_volume_flow>ET|T|)(?P<unit_for_time_adjustment>S2|S|)(?P<electrical_connection>K4|)(?P<type_of_limit_switch>QM|)(?P<monitored_limit_switch_position>AB|A|B|0|)(?P<power_supply_of_limit_switch>G24|)(?P<sep_3>/|)(?P<stroke_setting>10|11|12|)(?P<orifice_position>B|)(?P<orifice_diameter>08|10|)(?P<pressure_reducing_valve>D3|)(?P<seal_material>V|)(?P<additional_details>(.|[0-9])*)$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
typecode
Z4WH22E63-5X/
Z4WEH22E63-5X/6EG24NTK4/V
Z4WEH22E63-5X/6EG24N9ETK4QMBG24/B10
Z4WEH22E63-5X/6EG24NTK4QMAG24
Z4WEH22E63-5X/6EG24K4QMAG24SO32
Z4WEH22E63-5X/6EG24TK4QMAG24=CSA
Z4WEH22E63-5X/6EW230N9ETK4/B10
Z4WEH22E63-5X/6EW230N9ETS2K4/B10D3V
Z4WEH22E63-5X/6EG24N9K4/B10SO16
Z4WEH22E63-5X/6EG24N9ETK4/B08
Z4WEH22E63-5X/6EG24N9ETS2K4/B10D3
Z4WEH22E63-5X/6EG24N9TK4
Z4WEH22E63-5X/6EW230N9ETS2K4/B10D3
Z4WEH22E63-5X/6EG24ETK4QMAG24/B10D3
Z4WEH22E63-5X/6EG24N9ETK4/B10D3
Z4WEH22E63-5X/6EG24TK4QMAG24
Z4WEH22E63-5X/6EG24N9ETS2K4/B10
Z4WEH22E63-5X/6EW110N9ETS2K4/B10D3
Z4WEH22E63-5X/6EG24ETK4/B08
Z4WEH22E63-5X/6EG24N9ETS2K4QMBG24/B10
Z4WEH22E63-5X/6EG24ETK4QMAG24/B10
Z4WEH22E63-5X/6EG24N9K4QMAG24SO32
Z4WEH22E63-5X/6EG24N9TS2K4/B10
Z4WEH22E63-5X/6EG24N9TK4QMBG24
Z4WEH22E63-5X/6EG24N9K4/B10SO32
Z4WEH22E63-5X/6EG24N9EK4QMAG24/B10SO32
Z4WEH22E63-5X/6EG24ETK4QMABG24/B10
Z4WEH22E63-5X/6EG24N9ETK4/B10
Z4WEH22E63-5X/6EG24N9K4SO32
Z4WEH22E63-5X/6EG96N9ETK4QMAG24/B10
Z4WEH22E63-5X/6EG24N9K4/B10VSO16
Z4WEH22E62-5X/6EG24N9ETK4/B10D3
Z4WEH22E63-5X/6EW110ETK4QMAG24/B10
Z4WEH22E63-5X/6EG24N9ETK4QMAG24/B10
Z4WEH22E63-5X/6EW110N9TK4
Z4WEH22E63-5X/6EG24TK4QMABG24SO32
Z4WEH22E63-5X/6EG24N9K4QMAG24/B10SO16
Z4WEH22E63-5X/6EG24N9ETK4/B10V
Z4WEH22E63-5X/6EG24K4QMAG24SO16
Z4WEH22E63-5X/6EG24N9ETK4QMABG24/B10
Z4WEH22E63-5X/6EG24N9TK4QMAG24/B10
Z4WEH22E63-5X/6EG24N9ETK4QMAG24/B10V
Z4WEH22E63-5X/6EG96N9TK4/B10V
Z4WEH22E63-5X/6EG24N9ETK4QMAG24/B10D3
Z4WEH22E63-5X/6EG24ETK4QMBG24/B10
Z4WEH22E63-5X/6EG24N9TK4QMAG24/B10D3
Z4WEH22E63-5X/6EG24TK4QMBG24/B10
Z4WEH22E63-5X/6EW110N9ETK4/B10D3
Z4WEH22E63-5X/6EG24N9EK4QMAG24/B10D3SO32
Z4WEH22E63-5X/6EG24TK4QMABG24/B10
Z4WEH22E63-5X/6EG24N9K4QMABG24SO32
Z4WEH22E63-5X/6EG24N9ETK4QMBG24/B10V
Z4WEH22E63-5X/6EG24NTK4
Z4WEH22E63-5X/6EG24N9DK23L
Z4WEH22E63-5X/6EW110N9ETS2K4/B10D3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)