package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^( *(?:\"[^\"]*\" *, *){3})\"[^\"]*\"|\"[^\"]*\"((?: *, *\"[^\"]*\"){3} *)$`)
var str = `"00001","Open","2020-10-23 12:45","2022-10-20 15:48","Error not found","Alex Smith","NO ERROR","ErrorApp","FOB","CNSHA","GB","Plane","MODEL","2020-10-24 00:00","New","1","","2022-10-20 15:48", "Yes", "No", "Completed"`
var substitution = "$1""$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}