package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^"[^"\\]*(?:\\.[^\"\\]*)*"$|^'[^'\\]*(?:\\.[^'\\]*)*'$|^\s*["'][^"'\\]*|["']\s*$|\\.|(["'])[^"'\\\n]*`)
var str = `"Some Text"
"Some more Text"
"Even more text about \"this text\""
"Ol' 8 o'clock"
'8 o'clock'
'8 o'clock'
'Ol' 8 o'clock'
""B"
"\"B"
"\\"B"
"\\\"B"
"\\\\"B"`
var substitution = "\\$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}