const regex = new RegExp('^"[^"\\\\]*(?:\\\\.[^\\"\\\\]*)*"$|^\\'[^\\'\\\\]*(?:\\\\.[^\\'\\\\]*)*\\'$|^\\s*["\\'][^"\\'\\\\]*|["\\']\\s*$|\\\\.|(["\\'])[^"\\'\\\\\\n]*', 'gm')
const str = `"Some Text"
"Some more Text"
"Even more text about \\"this text\\""
"Ol' 8 o'clock"
'8 o'clock'
'8 o'clock'
'Ol' 8 o'clock'
""B"
"\\"B"
"\\\\"B"
"\\\\\\"B"
"\\\\\\\\"B"`;
const subst = `\\$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);