use strict;
my $str = 'Type: Game Opponent: Balder-Woody Area School District Bus: 2:00PM Dismissal: 1:30PM Est.return:
Type: Game Opponent: Balder-Woody Area School District Dismissal: 1:30PM Bus: 2:00PM Est.return:';
my $regex = qr/(?<=Opponent: ).*?(?= Bus| Dismissal)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}