$re = '/(?<=Opponent: ).*?(?= Bus| Dismissal)/m';
$str = 'Type: Game Opponent: Balder-Woody Area School District Bus: 2:00PM Dismissal: 1:30PM Est.return:
Type: Game Opponent: Balder-Woody Area School District Dismissal: 1:30PM Bus: 2:00PM Est.return:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);